Aqueles que usam o Twitter no N900 não possuem lá muitas opções. O mais utilizado é o Witter, mas ele sofre de um grave problema: é feio e pouco amigável (a interface dele é muito confusa).

Mas há uma luz no fim do túnel!


Como dá para ver pelas imagens, a aparência do programa é muito agradável. E bem rápido!

Ainda está cru, tanto que é uma versão alpha e não está nos repositórios. Mas acredito que é utilizável, apesar de alguns probleminhas que eu tive.

A instalação não é tão simples…é preciso instalar alguns pacotes “na mão”, e tudo via terminal. O primeiro passo é baixar o programa no site…e colocá-lo em algum lugar do N900 (lembre onde o deixou!). Caso o aparelho abra o Gerenciador de Aplicativos para tentar instalá-lo, muito provavelmente irá falhar.

O próximo passo é ir pelo terminal, como root, até o lugar onde deixou o programa e digitar dpkg -i twitterbox-0.1.1.deb (neste momento é esse o nome do arquivo, mas pode mudará, quando uma nova versão for lançada):

Nokia-N900-51-1:/home/user/MyDocs# dpkg -i twitterbox-0.1.1.deb
Selecting previously deselected package twitterbox.
(Reading database ... 28259 files and directories currently installed.)
Unpacking twitterbox (from twitterbox-0.1.1.deb) ...
dpkg: dependency problems prevent configuration of twitterbox:
 twitterbox depends on libqt4-maemo5-network; however:
  Package libqt4-maemo5-network is not installed.
dpkg: error processing twitterbox (--install):
 dependency problems - leaving unconfigured
Processing triggers for catorise ...
############################################################################
Errors were encountered while processing:
 twitterbox

Lendo atentamente o que é exibido, vemos que ele reclamou da falta do pacote libqt4-maemo5-network (no meu caso…no seu pode ser outro como podem ser vários). Aí vai ter que instalar todos aqueles que ele reclamar, usando este comando (como root também):

apt-get install nome-do-pacote

Que no meu caso, foi assim:

apt-get install libqt4-maemo5-network

Importante dizer que o apt-get irá baixar e instalar o pacote, portanto uma conexão ativa à internet é necessária, assim como os repositórios estarem no ar.

Eu acredito que o programa possa ter muito futuro, e quem sabe nos faça esquecer da petição para uma versão do Gravity para o N900.

E uma perguntinha para os desenvolvedores: há algum suporte oficial do INdT ao programa?

É só uma dúvida mesmo, que se tendo uma resposta positiva é um fato a se comemorar!! Tanto quanto saber que o PySide (o “porte” do Qt para uso no Python) tem muitas mãos brasileiras no seu desenvolvimento (se não forem todas)!!

Aliás….como estou apanhando para converter o PySafe pra Qt…. 🙂